CÓMO INSTALAR EL PLUGIN JAVA JRE1.5.0_08 EN UBUNTU

Bueno este es mi primer howto y espero que os sirva. Lo he sacado de la guía wiki de ubuntu dapper y lo he corregido porque hay algún error.El link en cuestión es: http://www.guia-ubuntu.org/dapper/index.php/Java

Se trata de instalar el paquete de java JRE 1.5.0_08, para ello primero y desde la terminal hacemos:

$ sudo apt-get install java-package
$ sudo apt-get install fakeroot

Con estos dos comandos instalaremos java-package y fakeroot, esto lo hacemos para poder convertir un fichero .bin en .deb.
Ahora nos bajamos el java que queremos instalar, para ello lo bajamos de la siguiente página:

http://java.com/en/download/manual.jsp

De los que hay elegimos el que pone Linux (self-extracting file) Para los de 64 bits elegir Linux64 (self-extracting file)
Una vez bajado lo guardamos en nuestra carpeta home. Después desde terminal tecleamos:

$ fakeroot make-jpkg jre-1_5_0_08-linux-i586.bin

Esto nos convertirá el .bin en .deb. Ahora sólo hay que instalar el .deb, para ello desde terminal:

$ sudo dpkg -i sun-j2re1.5_1.5.0+update08_i386.deb

Si quréis en vez de hacer este último paso así lo que podéis hacer es darle un doble click al .deb que se creó en el último paso.

Bueno ahora lo que haremos es asegurarnos de que el ordenador funciona con ésta última versión, para ello desde terminal tecleamos:

$ sudo update-alternatives –config java

Y nos aparecerá algo como esto:

There are 4 alternatives which provide `java’.

Selection Alternative
———————————————–
1 /usr/bin/gij-wrapper-4.1
+ 2 /usr/lib/jvm/java-gcj/jre/bin/java
* 3 /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
4 /usr/lib/j2re1.5-sun/bin/java

Press enter to keep the default[*], or type selection number: 4

Como véis nos aparece un menú con distintas opciones, en mi caso yo he tenido que elegir la 4. Vosotros en vez de 4 opciones podréis tener menos o más, pero sea el número que sea aseguraos que la que elegís sea la opción que pone /usr/lib/j2re1.5-sun/bin/java
Para estar seguros de lo que habéis hecho teclead en terminal:

$ java -version

Y os tiene que aparecer lo siguiente para que esté correcto:

java version “1.5.0_08”
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_08-b03)
Java HotSpot(TM) Client VM (build 1.5.0_08-b03, mixed mode, sharing)

Y ya está instalado correctamente. Os sugiero que esto os lo copiéis antes aparte y hagáis la instalación con los navegadores cerrados.

Ahora lo que haremos es que nuestro OpenOffice tenga el soporte del Java que hemos instalado, para ello abrimos office y nos vamos a Herramientas->Opciones, nos saldrá una ventana en la que pulsaremos en la opción Java y elegiremos el java de la versión que hemos instalado, para una mayor visualización de lo que hay que hacer ver la imagen:

Vale, ahora lo haremos para eclipse3.2, para ello abrimos eclipse, elegimos Window->Preferences..->Installed JRE’S->Add y buscamos la ruta en donde lo tenemos instalado, en mi caso es: /usr/lib/j2re1.5-sun, le decimos que ok y lo marcamos. Para una mayor aclaración pinchad en la siguiente imagen:


Un saludo y espero que os sirva. Si hay algún error os agradecería que me lo dijeráis para poder subsanarlo

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s