Cómo Instalar PSPPIRE

Hola, hoy voy a explicaros cómo instalar pspp + psppire (entorno gráfico de pspp). En los repositorios sólo podemos instalar pspp. PSPP es un programa para uso en la rama de Estadística.
Bueno vamos allá. Lo primero es instalar las dependencias, para ello abrimos terminal y escribimos:

$sudo apt-get install autoconf automake1.9 gnulib gettext gettext-base texinfo smake build-essential pkg-config subversion subversion-helper-scripts subversion-tools libgsl0 libgsl0-dbg libgsl0-dev libperl5.8 perl perl-base perl-modules libncurses5 libncurses5-dbg libncurses5-dev libreadline5 libreadline5-dbg libreadline5-dev libplot2c2 libplot-dev plotutils libgtk2.0-dev libgtk+2.0-directfb-dev libglade2-dev cvs libcvsservice0 gcvs libguile-dev

Después de todo esto hay que bajarse el pspp, para ello abrimos terminal y escribimos:

$ cvs -z3 -d:pserver:anonymous@cvs.savannah.gnu.org:/sources/pspp co pspp

$cvs -z3 -d:pserver:anonymous@cvs.savannah.gnu.org:/sources/gnulib co gnulib

Una vez bajado el PSPPIRE hacemos desde la terminal:

$cd pspp

$make -f Smake

$./configure

$make

$sudo make install

Y ya estará instalado, para hacerlo correr desde terminal escribiremos:

$psppire

Y nos aparecerá la siguiente pantalla:


Para más información Pinchad Aquí
Saludos🙂

25 comentarios en “Cómo Instalar PSPPIRE

  1. Hola, el PSPPIRE es también para Estadística, pero su entorno gráfico de ventanas es mucho mejor que el de R, además hay gente que no son matemáticos y con éste les sobra para trabajar(biólogos, veterinarios, etc)
    Saludos

  2. Seguí el procedimiento pero al final me aparece después de darle
    $psppire
    error: Unknown command $make.
    warning: This command not executed.
    warning: The rest of this command has been discarded.

    Tampoco descargó una librería del PSPPIRE. El PSPP lo había instalado con synaptic.

  3. Hola Carlos, tienes que descargar el paquete que pongo en el tuto.
    Cuando pones make no se ejecuta porque cuando haces ./configure te sale error por falta de alguna libreria.
    Vuelve hacer ./configure y posteame aquí el error que te sale para poder ayudarte.
    Perdona que no te haya contestado antes, lo siento.
    No dudes en postearme el problema que tengas.
    Saludos🙂

  4. Lo hice todo bien hasta el make -f Smake. Me dice lo siguiente

    You may need to use the following Makefile variables when linking.
    Use them in _LDADD when linking a program, or
    in _a_LDFLAGS or _la_LDFLAGS when linking a library.
    $(LTLIBICONV) when linking with libtool, $(LIBICONV) otherwise

    Don’t forget to
    – add “gl/Makefile” to AC_CONFIG_FILES in ./configure.ac,
    – mention “gl” in SUBDIRS in Makefile.am,
    – mention “-I gl/m4” in ACLOCAL_AMFLAGS in Makefile.am,
    – invoke gl_EARLY in ./configure.ac, right after AC_PROG_CC,
    – invoke gl_INIT in ./configure.ac.
    echo ‘*’ > gl/.cvsignore
    echo ‘*’ > gl/m4/.cvsignore
    libtoolize –force –automake
    autopoint –force
    autopoint: *** The AM_GNU_GETTEXT_VERSION declaration in your configure.ac file requires the infrastructure from gettext-0.16.1 but this version is older. Please upgrade to gettext-0.16.1 or newer.
    autopoint: *** Stop.
    make: *** [all] Error 1

    ¿Como puedo actualizar el gettext ese??
    Muchas gracias !!

  5. Hola, parece ser que han puesto una nueva versión de PSPP, te pongo el enlace de descarga de gettext
    ftp://mirrors.kernel.org/gnu/gettext/gettext-0.16.1.tar.gz
    Cuando te lo descargues lo descomprimes y haces
    ./configure
    make
    sudo make install
    Si no se te instala bien desde synaptic instala gfortran y g++, si no tienes jdk6 instalado tienes en mi blog un tuto sencillo para instalarlo desde synaptic
    https://crislosi.wordpress.com/2007/02/21/instalar-java-jdk6-desde-synaptic/

    Yo lo acabo de instalar sin problemas
    Una vez tengas instalado gettext vuelve a pspp y haz lo de make -f Smake

    Si lo ves muy complicado te aconsejo que te instales R-CRAN que es mucho más sencillo de instalar, en mi blog también tienes un tuto de cómo instalarlo correctamente y desde repositorios.
    Pero si te es necesario psppire te recomiendo que tengas mucha paciencia para instalarlo.

    Saludos, y no dudes en postear si tenes dudas o no te aclaras en algún paso.

    ¡ Ánimo !🙂

  6. Verás, ya intenté instalar el R y nada…La verdad es que soy bastante novato (aunque ya he hecho migrar a 4 amigos más, jeje) en Linux. Por eso lo intentó con psppire, porque necesito un programa estadístico con interfaz gráfica.
    Ahora, al hacer el Smake me sale esto

    Copying file po/remove-potcdate.sin
    aclocal -I m4 -I gl/m4
    aclocal: macro `AM_PROG_MKDIR_P’ required but not defined
    aclocal: macro `gl_PRINTF_DIRECTIVE_A’ required but not defined
    aclocal: macro `AM_PROG_CC_C_O’ required but not defined
    aclocal: configure.ac: 13: macro `AM_PROG_CC_C_O’ not found in library
    aclocal: macro `AM_PROG_MKDIR_P’ required but not defined
    aclocal: macro `AM_PROG_MKDIR_P’ required but not defined
    make: *** [all] Error 1

    ¿qué significa?
    Muchas gracias por el tiempo y el interés…

  7. Sabes entonces qué es lo que me pasa?? Por que no me deja compilar el psppire ??

    En realidad no se bien que necesito. Soy sociólogo y uso SPSS de manera muy simple, sólo para hacer tablas de contingencia, comparación de medias y análisis de estadísticos (frecuencias, regresiones, C de pearson, chi-cuadrado, etc.)
    ¿Qué programa me recomiendas? Necesito que tenga interfaz gráfica porque, ya digo, no soy informático ni matemático…
    Qué tal rular el SPSS en Wine ?? Es posible?? Como se haría??
    Bueno, siento acosarte a preguntas, pero no es mucha le gente que usa linux para fines profesionales similares a los míos…
    Un saludo afectuoso
    Manuel

  8. Hola, vamos a intentarlo de nuevo, creo que he encontrado lo que falta, instala el paquete guile-dev

    sudo apt-get install guile-dev

    A ver si ahora hay suerte. Este parece ser el paquete de aclocal, lo que pasa es que yo instalé con anterioridad guile compilándolo para poner Anjuta .

    En cuanto al SPSS yo no lo he probado pero hay quien lo ha probado con wine y dice que le funciona, aunque muy lento y a veces da problemas. Si quieres puedes probar a ver.

    Saludos

  9. Bueno, siento ser tan TORPE con ésto…De todas formas no te apures por contestar ni solucionarme ésto, ya saldrá…

    Bien, el error sigue siendo el mismo

    aclocal -I m4 -I gl/m4
    aclocal: macro `AM_PROG_MKDIR_P’ required but not defined
    aclocal: macro `gl_PRINTF_DIRECTIVE_A’ required but not defined
    aclocal: macro `AM_PROG_CC_C_O’ required but not defined
    aclocal: configure.ac: 13: macro `AM_PROG_CC_C_O’ not found in library
    aclocal: macro `AM_PROG_MKDIR_P’ required but not defined
    aclocal: macro `AM_PROG_MKDIR_P’ required but not defined
    make: *** [all] Error 1

    porque el paquete guile-dev no existe, así que instalé libguile y guile-gnome-dev del synaptic…Y nada.

    ¿Qué me falta exactamente?
    De nuevo gracias…

  10. Hola Manuel, he intentado volverlo a instalar en mi Dapper pero ahora se me hace bastante jodido porque el psppire que hay de donde te lo descargas es nuevo y pide que los paquetes sean muy actuales, por ejemplo pide automake 1.10 que sólo se encuentra en feisty (ni siquiera en edgy), así que te recomiendo que si lo quieres instalar te pases a feisty ( ya es muy estable).
    Si quieres un entorno gráfico para calcular kurtosis, normal, poisson, frecuencias,etc puedes hacerlo con la hoja de cálculo de Openoffice y un manual de Excel.
    Si no prueba a instalar R como lo pongo en mi tuto, no tienes que hacer nada, sólo añadir dos repositorios a tu sources.list y poner sudo apt-get update y sudo apt-get install nombre del fichero y chimpún todo resuelto.

    Saludos

  11. Intentaré lo de R y si no actualizaré, ya que de todas formas lo estaba pensando hacía tiempo.
    En fin, cuando lo consiga del todo, ya te avisaré…
    Muchísimas gracias por todo. Un saludo.
    Manuel

  12. hola Cristobal
    He actualizado a Feisty Fawn, me dio problemas por el Automake, y ya tengo el Automake 1.10
    Hago sin problemas el Smake, pero al hacer el ./configure, me dice esto

    checking for fseeko… (cached) yes
    checking for sin in -lm… yes
    checking for pl_newpl_r in -lplot… no
    checking for pkg-config… /usr/bin/pkg-config
    checking pkg-config is at least version 0.9.0… yes
    checking for GTK… configure: error: Package requirements (gtk+-2.0 >= 2.6.0) were not met:

    No package ‘gtk+-2.0’ found

    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.

    Alternatively, you may set the environment variables GTK_CFLAGS
    and GTK_LIBS to avoid the need to call pkg-config.
    See the pkg-config man page for more details.

    Creo que me faltan algunas librerias…me podrías ayudar.
    Gracias y un saludo afectuoso !!
    Manuel

  13. Hola Manuel, verás me he trasladado a otro sitio el blog, la nueva dirección es:

    http://www.tobal.lynksee.com/blog

    allí tengo la misma entrada de psppire con los mismos comentarios, en concreto en
    http://tobal.lynksee.com/blog/2006/12/31/como-instalar-psppire/

    Si no es mucha molestia te agradecería que hicieses un copiar y pegar de tu comentario allí para poder atenderte mejor, gracias por tu comprensión.

    Mientras averiguo qué se puede hacer.

    Saludos

  14. Hola,
    Resulta que he descargado pspp-0.4.0.1.tar.gz
    utilizo
    tar -xfv pspp-0.4.0.1
    para desempaquetar (o algo así) luego utiilizo
    ./configure
    a continuación
    make
    y me dice que no encuentra archivo para aplicar
    verifique que make estuviera instalado y si lo está. intenté con deb-make y nada… no se porque no puedo completar la instalación.
    ¿Me puedes ayudar?

  15. Buenas todos, ando correteando el manual del pspp en español, ¿alguien ayuda?, igualmente si alguien pudiera tener un archivo que me sirva de demo para mis alumnos de medicina, gracias

Responder

Introduce tus datos o haz clic en un icono para iniciar sesión:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

Google+ photo

Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

Conectando a %s